Help with deinterlacing DVD rips

Hopefully I'm allowed to post this here. You may have noticed, if you've seen any of my whinging about streaming services leaving all of their content filmised even if it was originally aired in 50/60fps interlaced, that I'm awfully picky when it comes to frame rates.

For a long time, I've been digitising my DVDs and using Handbrake to deinterlace and transcode everything into 50fps progressive. Only recently, however, I've noticed an issue. I wish I noticed this years ago when I started doing this thing, but better late than never, I suppose.

It's only noticeable on something with constant motion, but my output file seems to be dropping/skipping frames and causing a juddery effect. I couldn't think of anywhere better to upload it, but I've attached a WeTransfer link that contains a few seconds of a Stanley Baxter special featuring a Nationwide graphic spinning around - . You'll hopefully notice that every half second or so, the spinning skips/judders. It's also very noticeable during any scrolling end credits, where it looks like the credits jump a couple of frames every half second or so.

I've tried both Decomb and Yadif with every combination of preset (except EEDI2 because I'll be dead by the time I finish encoding) as well as trying peak framerate and constant framerate, and changing the overall quality of the video. I've also tried using Same as Source for framerate and that just gives me a 25fps output. I've also tried to Google this issue with all sorts of different wordings and can't seem to find a solid solution.

I don't suppose anybody here might be able to help me please?

Do you need to use Handbrake for a smaller file?

You'd probably do better to MakeMKV it and then Handbrake from that, if you need a smaller file - MakeMKV will generate a massive file (to the size of the original media, so up to 4.7Gb/9.4Gb for single/dual layer media), but it doesn't compress it any further than it already is, whereas Handbrake will squash the bejesus out of it and then some more.

MakeMkv can rip DVDs to ISO as well (can't do Blu-Ray but it will make DVD ISOs). That'll give you the "digitising" of which you speak, and VLC will play the ISO, so you get the best of both worlds with one application.

I had this picture problem if you rip a DVD directly from Handbrake, and if the source was videotape material - it was fine with film inserts/movies, but it made a hash of videotape material, as Noggin explained at the time: 

Since I wrote that post I have since gone back to this project (after buying a 4Tb drive in the sales) and I'm now ripping DVDs to ISOs and Blu-Ray to MKV files. I used to use a Pi for playback but I wanted an all-in-one solution so I have now a Firestick 4k with Kodi sideloaded on it. It works and I'm happy.
[-] The following 1 user Likes Neil Jones's post:
  • Ma76

I'll give it a try and report back. Thanks!

I've tried playing with MakeMKV but I can't get the results I'm looking for. When I've converted the MKV using Handbrake to try and deinterlace it, I end up with the same jerkiness as seen in the clip. I also can't seem to deinterlace in software using VLC, for what that's worth.

I'm a complete newbie to FFMPEG but I tried looking through the thread you posted. I tried to give w3fdif a go but I kept getting error messages that I couldn't understand about a value of something or other.

Because everything that comes out of MakeMKV is 25fps, I can't decipher whether it's an issue with the DVD rip or with Handbrake's deinterlacing. As for just keeping the ISOs, I'm pretty tight for space - my collection has amassed over 7tb so far - so compression is sadly non-negotiable. Even so, I can't seem to find a way around deinterlacing and playing back at 50fps straight from the DVD files.

As alluded to in the post I linked to, MakeMKV doesn't affect the content of the files. "MakeMKV literally just takes the video and audio streams from the DVD VOB files and puts them in a Matroska MKV wrapper - leaving the actual video and audio data untouched. "

I only have had to deinterlace stuff that was recorded exclusively on video, as you get the whole "judder judder judder" thing if you just do it with Handbrake. It works fine on MakeMKV. That's all I can tell you based on my experience.

I think you're doing something wrong, but I don't know what you're doing. How are you playing your ripped files? Kodi? VLC? Some other software/solution? Something else? Note that also was alluded to in the TV Forum thread: "Never judge any video quality on a laptop, PC monitor, tablet or phone ... Only ever make judgements on a display that is correctly displaying your content at the right refresh rate."

You could just MakeMKV the main video of a DVD and play that in whatever solution you're using and see what happens.

I've played the encoded file that gives me that judder that I linked to in the original post in VLC, and I've played with VLC's own deinterlacing settings to see if that's having an effect, which it isn't. I've also put the video file on a USB stick and played it on an Xbox Series S just to rule out the issue being exclusive to my laptop/VLC, and the judder was still there on my TV. Just for safety, I played the DVD I ripped on my PS5 just to ensure it wasn't anything to do with the disc itself, but that played without the judder at 50fps (the spinning Nationwide clip I linked to span smoothly with no "skip" every half second or so) so the DVD definitely looks the way it's supposed to.

The one thing I can't rule out is if it's something to do with the DVD files after they've been ripped. I've tried two different DVD rippers as well as MakeMKV, and I don't have anything that plays VOB or ISO files that will also deinterlace without the frame rate being reduced to 25fps. I'd still rather have a file that plays in 50fps regardless where it's played, rather than rely on any filters in a video player that might not be replicated if I watch it elsewhere.

One thing I have noticed, now I'm looking out for it, is my own captures seem to have the same judder. These are shows I've captured myself from TV using a capture card recording at 50fps, and then edited/compressed in Premiere Pro. I've gone back to look at these and noticed that end credits are having that same jerky effect every half second like the clip I posted. As I say, it's only really noticeable during things like credits or panning shots with continuous movement. But those videos haven't gone anywhere near Handbrake...

As you say, I probably am going wrong somewhere or misinterpreting something obvious. I feel like I'm running out of options to try, though. Perhaps I'm just having a mental breakdown...?

I have this same problem also. ISO playback in VLC (Windows) or Infuse (iOS) doing their own deinterlacing gives the playback wanted. Trying to reencode to achieve the same result via XMedia or Handbrake just ends up with a janky mess. I’ve given up but will keep an eye here incase of a miracle solution.

I always just keep everything I digitise interlaced, then let whatever player I use deinterlace the file. The deinterlacing in these types of video rendering software is often flawed some way, and then when you render it as 50p, any deinterlacing artifacts are baked into the file, so it's best to at least keep a file in the proper interlaced form even if you are making 50p copies, then you can also go back to it later if you improved software. Similar with scaling to different resolutions.

I do make 50p copies of files when I share them online because you can be pretty sure different hardware and software that people are using will handle progressive video properly (unlike interlaced files where you get all sorts of wacky variations in how it's treated), but I always keep the original 50i files.
[-] The following 1 user Likes James2001's post:
  • Ma76

As VLC has been mentioned, if this is on a laptop or a PC (and assuming you're running Windows) the default refresh rate is almost always 60Hz on monitors/screens, for boring technical reasons only sad people like me understand.

You may not be able to change this on a laptop but you should be able to on a desktop, and even failing that you should be able to be forced through the monitor/TV settings to a 50Hz refresh rate.
[-] The following 1 user Likes Neil Jones's post:
  • Ma76

The solution must be ffmpeg using the w34dif filter to turn it 50p it does a great job at deinterlacing and i do that before putting onto YouTube for example if the source material you are working with is interlaced. After work I can put in a line of code which you can try on your source material.

Forum Jump:

Users browsing this thread: 1 Guest(s)